Home > Error Unable > Error Unable To Open Port Invalid Command Name Compiler.blacklist

Error Unable To Open Port Invalid Command Name Compiler.blacklist

c. _______________________________________________ Help-octave mailing list [hidden email] https://mailman.cae.wisc.edu/listinfo/help-octave c.-2 Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave update FYI: one of the first things that package installation does is check the dependencies; if not all present it bails out. What is the proper translation of Breishit (Gen.) 40:16? The new 'log' action can also be used to view the log for a port. *) Command line options can be abbreviated if unambiguous. *) New actions: rdeps, rdependents, setrequested, unsetrequested this contact form

As the io package installation error indicates, the Octave-3.7.7+ bundle can't build binary packages and AFAIK the statistics package has some binary (to-be-compiled) functions as well. It's driving me crazy, honestly. I DO have xcode tools installed, as well as the latest XCode, and ALL software on my machine that's in the App Store is currently up-to-date. ! If a formula fails to build, uninstall MacPorts/Fink and try > again. > Error: No available formula for octave > Searching taps... > homebrew/science/octave > > so how should i proceed?

I suggest you not use both Fink, Macports, and/or homebrew simultaneously. I don't even have OSX. My machine is running Mountain Lion and Xcode is version 4.6. If that fails, you can try to get more information on the type of failure using sudo port -d selfupdate.

None of this stuff was happening until Mavericks - the ONLY problem I was having before Mavericks was with curl... i've recently uploaded OS to 10.9 and this is maybe related to the problems i meet in the installation, and Ben told me before. that's the list of ports i can't upgrade [19:04:53] the error was posted above: [19:04:58] Error: Unable to open port: invalid command name "compiler.blacklist-append" [19:05:05] what you Switch to DuckDuckGo Search February 27, 2013< | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 |

this is confusing [12:28:42] i'm updating because of the svn errors i had [12:28:53] version conflicts and outdates and so on [12:33:23] *** bitpup has joined #macports [12:35:46] what should i do? [18:44:54] i couldn't get help from google [18:45:05] *** maxagaz has quit IRC [18:52:30] *** veonik has joined #macports [18:52:52] *** kateweb has joined #macports [18:55:43] Finally, i got the latest version, that's the 3.7.7 and if i now try to install statistics i got the message statistics needs io >= 1.0.18 and thus, if if i https://trac.macports.org/ticket/41137 Can a creature with multiattack make more than one attack as part of a readied attack?

Still, for your specific needs I think getting version 3.6.4 would be better. comment:8 in reply to: ↑ 7 Changed 3 years ago by [email protected]… Replying to [email protected]…: Did you run xcode-select --install after installing Mavericks? The progress bar hasn't moved from this spot in over 15 minutes. comment:2 Changed 3 years ago by [email protected]… Yes, I can confirm that a sudo port selfupdate fixed the issue.

Now I can use the package, and there are lots of functions...but unfortunately there's not the function dendrogram which should be there! http://octave.1599824.n4.nabble.com/octave-update-td4658725.html no configure: error: in `/opt/local/var/macports/sources/rsync.macports.org/release/base': configure: error: C compiler cannot create executables See `config.log' for more details comment:13 Changed 3 years ago by neverpanic (Clemens Lang) Now check for /opt/local/var/macports/sources/rsync.macports.org/release/base/config.log and You're a saint - thank you so much! Install the statistics package with the -nodeps option.

The fully thing behind this is that i uploaded the operating system just to use the statistic package (that needed a newer version of octave respect to the one i had, weblink When I try to do the installation in Pallet instead, nothing happens after choosing install and pressing "start." Thank you for any help you can provide xcode osx boost port macports I think I've no choice and will wait some weeks until these problem get fixed :(. Thank you again.

You signed out in another tab or window. In your case, MacPorts apparently determined that gcc-4.2 does exist, but running it caused it to crash, because /usr/bin/i686-apple-darwin11-gcc-4.2.1 doesn't exist. Theorems demoted back to conjectures Has Darth Vader ever been exposed to the vacuum of space? navigate here comment:5 Changed 4 years ago by [email protected]… Did you have an old version of Xcode - such as version 3.2.6 - in the /Developer directory?

Last edited 3 years ago by [email protected]… (previous) (diff) comment:21 follow-up: ↓ 22 Changed 3 years ago by neverpanic (Clemens Lang) Resolution set to wontfix Status changed from new to closed That Can you attach /opt/local/var/macports/sources/rsync.macports.org/release/base/config.log? Board index»Information It is currently Wed Dec 21, 2016 10:58 pm|All times are UTC - 6 hours [ DST ] Delete all board cookies|The team|Top Hosted By Skip to content

Thank you, kbell Attachments (2) port selfupdate -d.txt​ (3.6 KB) - added by [email protected]… 3 years ago.

Alas that's not officially released yet, but I've put up a development io package snapshot that will only work with Octave >= 3.7.2 here: https://savannah.gnu.org/patch/index.php?8099Philip jacopo rocchi Reply | Threaded Open SO - any help appreciated. Thanks c.-2 Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave update On 2 Nov 2013, at 12:46, jacopo I'm a developer for a living and it would take at least 10+ hours to recreate everything in my environment.

https://trac.macports.org/wiki/MailingListsFor help using Fink, please use the appropriate mail list. Did you really need the latest statistics package? It's at just under 20 minutes now, and still hung on the very last bit. his comment is here Philip PhilipNienhuis Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave update In reply to this post by jacopo

comment:4 Changed 4 years ago by [email protected]… That did it for me. This points to a broken Xcode command line tools installation. If you see new output coming up, leave it running, it might actually take quite a while. Check the 'Clean Upgrade' section of /sw2/share/doc/fink/INSTALL or /sw2/share/doc/fink/INSTALL.html for information about how to proceed. 'install' operation not permitted.

if so, you'll also want to download and install the latest macports [19:09:50] sudo /Developer/Library/uninstall-devtools --mode=all [19:10:01] yea - probably [19:10:34] geekosaur, i updated macports this morning [19:10:45] c. _______________________________________________ Help-octave mailing list [hidden email] https://mailman.cae.wisc.edu/listinfo/help-octave bpabbott Reply | Threaded Open this post in threaded view ♦ ♦ | Report Content as Inappropriate ♦ ♦ Re: octave update I think I've no choice and will wait some weeks until these problem get fixed :(. It's a totally separate process!

are you then running an ancient macports that doesn't know about the compiler blacklist? Apple's installer tells users this is only going to take a minute, but that's not true and we have no influence over that. If so, you should run the uninstall script for it: From memory: sudo /Developer/Library/uninstall-devtools --mode=all comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt) There's probably some overlap between Xcode 3.2.6's Anyway I'm not determinate at all to keep on trying 3.7.7+ and really like to install 3.6.4 but using mac port and fink made me already waste a lot of time

From what I see above, I think that macports and fink need to be installed from scratch because your versions do not work anymore after you updated to Mavericks, that's just comment:2 Changed 4 years ago by [email protected]… Thanks for the reply. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 0 Star 1 Fork 0 corneltek/MacPorts Code Issues 0 Pull requests 0 Projects I am really sorry for your frustration.

The version you actually want is 3.6.4. If that doesn't help either, run cd /opt/local/var/macports/sources/rsync.macports.org/release/base && PATH=/bin:/usr/bin CC=/usr/bin/llvm-gcc-4.2 ./configure --prefix=/opt/local --with-tclpackage=/Library/Tcl --with-install-user=root --with-install-group=admin --with-directory-mode=0777 --enable-readline and check for the file again. if i write on > the shell > sudo port install octave-devel +atlas+docs > i get: > Error: Unable to open port: invalid command name "compiler.blacklist-append" > while if i use thus i download it and then i typed pkg install io-1.3.3.tar but that's what i get: /Applications/Octave.app/Contents/Resources/bin//mkoctfile: line 378: /Applications/Octave.app/Contents/Resources/bin/gsed: No such file or directory make: *** [csvexplode.oct] Error 1 mkoctfile

I'll report back as soon as it's done and I try the selfupdate. nothing there [19:03:33] sorry mf2k_mp this one: http://pastebin.com/0QPpytmP [19:03:46] There's no error there. [19:03:51] show me the complete error [19:04:02] what you have pasted is totally valid Therefore, the ticket can be closed.

© Copyright 2017 netfiscal.com. All rights reserved.